summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:46:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:29 +0100
commita9d4e98ddf2de49bb821ebd028fae4a930d12fc6 (patch)
tree6421bc9a428f1cef5e2da502d1ce89eff62cbdae /dev-python/sexpdata
parentdev-python/sarge: Switch to PEP 517 build (diff)
downloadgentoo-a9d4e98ddf2de49bb821ebd028fae4a930d12fc6.tar.gz
gentoo-a9d4e98ddf2de49bb821ebd028fae4a930d12fc6.tar.bz2
gentoo-a9d4e98ddf2de49bb821ebd028fae4a930d12fc6.zip
dev-python/sexpdata: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sexpdata')
-rw-r--r--dev-python/sexpdata/sexpdata-0.0.3-r2.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/sexpdata/sexpdata-0.0.3-r2.ebuild b/dev-python/sexpdata/sexpdata-0.0.3-r2.ebuild
new file mode 100644
index 000000000000..cef2841d5473
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-0.0.3-r2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="https://github.com/jd-boyd/sexpdata"
+SRC_URI="https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+distutils_enable_tests nose