summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-02-03 13:21:12 -0800
committerPatrick McLean <chutzpah@gentoo.org>2017-02-03 13:21:12 -0800
commitbb73b416efaeae146ec8ac26dc0a3d7196e5cb5a (patch)
treee99eb1c77074fe2106a8c15734d2d7e82ccb21cb /dev-python/sh/sh-1.12.9.ebuild
parenttoolchain.eclass: fix a typo in a comment (diff)
downloadgentoo-bb73b416efaeae146ec8ac26dc0a3d7196e5cb5a.tar.gz
gentoo-bb73b416efaeae146ec8ac26dc0a3d7196e5cb5a.tar.bz2
gentoo-bb73b416efaeae146ec8ac26dc0a3d7196e5cb5a.zip
dev-python/sh: Version bump to 1.12.9
Gentoo-Bug: 608016 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/sh/sh-1.12.9.ebuild')
-rw-r--r--dev-python/sh/sh-1.12.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sh/sh-1.12.9.ebuild b/dev-python/sh/sh-1.12.9.ebuild
new file mode 100644
index 000000000000..cb703741760d
--- /dev/null
+++ b/dev-python/sh/sh-1.12.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=(python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.9-python2-unicode-tests.patch"
+)
+
+python_test() {
+ ${PYTHON} test.py || die
+}