summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-13 18:55:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-13 19:09:24 +0200
commitff977d0c29b572f604e20ae6d69509fce5e3007c (patch)
tree79e55f03402768550987fea3a3049ce8b771e432 /dev-python/shapely
parentdev-python/openstacksdk: Bump to 0.102.0 (diff)
downloadgentoo-ff977d0c29b572f604e20ae6d69509fce5e3007c.tar.gz
gentoo-ff977d0c29b572f604e20ae6d69509fce5e3007c.tar.bz2
gentoo-ff977d0c29b572f604e20ae6d69509fce5e3007c.zip
dev-python/shapely: Bump to 1.8.5_p1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/shapely-1.8.5_p1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 7f9e483c229f..b00003454e29 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-1.8.4.gh.tar.gz 322701 BLAKE2B 79cca2290b8e32ac146316feff4ccb332d47dd11ec4753f83618305c169e085629858c5e9d66fe281adda36be46eaebe996e2fe67dace1e6cbe9a7ca322c1c18 SHA512 8b57a2e83f8eb10a041f6a8d9170b84ed708a5835a16874761e5ccec0453ff34a282aeefb0367ab79c85216a68f5bb8b4b75503e81eaa3f7277f4036b8b0b242
+DIST shapely-1.8.5.post1.gh.tar.gz 323178 BLAKE2B 05ff22f972446da340714548f5a2ad233f8bac8bb0710a8c5444dc44e7d5ad0d2c2d37bc3ddb987f57accd065c75c9627752a6c6cb3590621e39812674c678e9 SHA512 99a406833ebd13cb3f88fb710ed66f545a0b128d201e82ff381de0214cde38c685a622f78e964d6d41fc9ba096bc62e63bf9da04d216dedf2f96bb1e3496d48f
diff --git a/dev-python/shapely/shapely-1.8.5_p1.ebuild b/dev-python/shapely/shapely-1.8.5_p1.ebuild
new file mode 100644
index 000000000000..cb3c65a36d9f
--- /dev/null
+++ b/dev-python/shapely/shapely-1.8.5_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/Shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/matplotlib
+
+src_prepare() {
+ rm -r _vendor || die
+ sed -i -e 's:_vendor\.::' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ rm -rf shapely || die
+ epytest
+}