summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2016-01-23 08:00:53 +0100
committerJohann Schmitz <ercpe@gentoo.org>2016-01-23 08:01:18 +0100
commit1ddc07eed736e619ba51f3f226f1bdfba03fa234 (patch)
tree0b9729e863d3ce3b6c2dbce10c43b112cfddafe4 /dev-python/shortuuid/shortuuid-0.4.3.ebuild
parentsys-apps/pkgcore: simplify docs build/install (diff)
downloadgentoo-1ddc07eed736e619ba51f3f226f1bdfba03fa234.tar.gz
gentoo-1ddc07eed736e619ba51f3f226f1bdfba03fa234.tar.bz2
gentoo-1ddc07eed736e619ba51f3f226f1bdfba03fa234.zip
dev-python/shortuuid: Version bump to 0.4.3; added support for test
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/shortuuid/shortuuid-0.4.3.ebuild')
-rw-r--r--dev-python/shortuuid/shortuuid-0.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/shortuuid/shortuuid-0.4.3.ebuild b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
new file mode 100644
index 000000000000..a746f39b1894
--- /dev/null
+++ b/dev-python/shortuuid/shortuuid-0.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator library for concise, unambiguous and URL-safe UUIDs"
+HOMEPAGE="https://pypi.python.org/pypi/shortuuid"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pep8[${PYTHON_USEDEP}] )"
+
+python_test() {
+ ${EPYTHON} ${PN}/tests.py || die "Tests failed with ${EPYTHON}"
+} \ No newline at end of file