summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-05 08:29:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-05 09:29:05 +0200
commit2eea6c0a753a007603c7556d337ce84b2743cb63 (patch)
tree34d8fd1b5505e7143d31c64bb7779b238c40e6a6 /dev-python/signature_dispatch
parentdev-python/typeguard: New package, needed for signature_dispatch (diff)
downloadgentoo-2eea6c0a753a007603c7556d337ce84b2743cb63.tar.gz
gentoo-2eea6c0a753a007603c7556d337ce84b2743cb63.tar.bz2
gentoo-2eea6c0a753a007603c7556d337ce84b2743cb63.zip
dev-python/signature_dispatch: Bump to 0.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/signature_dispatch')
-rw-r--r--dev-python/signature_dispatch/Manifest1
-rw-r--r--dev-python/signature_dispatch/signature_dispatch-0.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/signature_dispatch/Manifest b/dev-python/signature_dispatch/Manifest
index 8bc55852b1ee..8cb04a2dcf84 100644
--- a/dev-python/signature_dispatch/Manifest
+++ b/dev-python/signature_dispatch/Manifest
@@ -1 +1,2 @@
DIST signature_dispatch-0.1.0.tar.gz 8715 BLAKE2B c62f5d0b0b263e50215d588e83bab4b5ca6dff82f856ad6265a0bb2dd64e2a3a8dfd0b8989ec17424828575607bd4dccc5802ef072af271eddb88c2479e6b8e7 SHA512 687a1de540a61d274e93510d2c5a93c736a52587b0215aef91364e34ad8932b880361b53fb84e68f9c2083652fa97c759705b4d61bc74caeba73a4ff37b42785
+DIST signature_dispatch-0.2.0.tar.gz 11422 BLAKE2B 3e3297ef34bb4f7352fe867edd2c804d627d5f8e854b1551c88dcdea2f83a6e2cde9c0f088d263e405f29ccd7114717c9348dc59d60ccd00a4ebb84db800d398 SHA512 e2fedfe3260be641c319364a8f79b2d1444179c824e409fb8304352cc9f73fc2cfb8fbdab6788c14d08e716d4655cda72bc15b406596d43520f959973fc612c5
diff --git a/dev-python/signature_dispatch/signature_dispatch-0.2.0.ebuild b/dev-python/signature_dispatch/signature_dispatch-0.2.0.ebuild
new file mode 100644
index 000000000000..73c2bc0b51b2
--- /dev/null
+++ b/dev-python/signature_dispatch/signature_dispatch-0.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Execute the first function that matches the given arguments"
+HOMEPAGE="
+ https://github.com/kalekundert/signature_dispatch/
+ https://pypi.org/project/signature-dispatch/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ dev-python/typeguard[${PYTHON_USEDEP}]"