summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-28 15:47:28 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-11-28 16:09:28 +0100
commita5fb71270c92ea38d1e7ff0975132b85d661d985 (patch)
treec008f7c59f30fb8aeeae10cf5ca76ed4e4954f55 /dev-python/simpervisor/simpervisor-0.4.ebuild
parentdev-python/plotly-geo: enable py3.10 (diff)
downloadgentoo-a5fb71270c92ea38d1e7ff0975132b85d661d985.tar.gz
gentoo-a5fb71270c92ea38d1e7ff0975132b85d661d985.tar.bz2
gentoo-a5fb71270c92ea38d1e7ff0975132b85d661d985.zip
dev-python/simpervisor: new dep of jupyter-server-proxy
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/simpervisor/simpervisor-0.4.ebuild')
-rw-r--r--dev-python/simpervisor/simpervisor-0.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/simpervisor/simpervisor-0.4.ebuild b/dev-python/simpervisor/simpervisor-0.4.ebuild
new file mode 100644
index 000000000000..a4917e465cf2
--- /dev/null
+++ b/dev-python/simpervisor/simpervisor-0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python3 Supervisor library"
+HOMEPAGE="https://github.com/jupyterhub/simpervisor"
+SRC_URI="https://github.com/jupyterhub/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest