summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-02-16 15:13:37 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-02-16 22:09:09 +0100
commitcaeaa736e6db0a77d93de78fac6336fbb696cdf0 (patch)
tree4d0be10a821129349feb6c1fa78b1976809b66c2 /dev-python/simplebayes
parentmedia-gfx/pixie: Fix missing || die in previous commit (diff)
downloadgentoo-caeaa736e6db0a77d93de78fac6336fbb696cdf0.tar.gz
gentoo-caeaa736e6db0a77d93de78fac6336fbb696cdf0.tar.bz2
gentoo-caeaa736e6db0a77d93de78fac6336fbb696cdf0.zip
dev-python/simplebayes: initial commit
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/simplebayes')
-rw-r--r--dev-python/simplebayes/Manifest1
-rw-r--r--dev-python/simplebayes/metadata.xml17
-rw-r--r--dev-python/simplebayes/simplebayes-1.5.7.ebuild28
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/simplebayes/Manifest b/dev-python/simplebayes/Manifest
new file mode 100644
index 000000000000..aef312711c29
--- /dev/null
+++ b/dev-python/simplebayes/Manifest
@@ -0,0 +1 @@
+DIST simplebayes-1.5.7.tar.gz 19260 SHA256 71cb029768bd25c172bdb3bd37174d42f872da92c33329ec736c3748ffa3b4a7 SHA512 417af72db13418e5a9df2fdb642fc63ed3eb4fbbf88cc7252a9e3603d31e35ccb68ae5838d8bb7d77554c1820a9db8aa944c639af4eb6418babb9d360ef3ddbc WHIRLPOOL 826617d920c45411a138bc405f760229e79959b25f4cd7e3d6b4525cdd2e9fec43b88f0df011dd820a72484df5bf988e3a18b357fe2966e15a8349c686eba308
diff --git a/dev-python/simplebayes/metadata.xml b/dev-python/simplebayes/metadata.xml
new file mode 100644
index 000000000000..9d1e5c16ae1b
--- /dev/null
+++ b/dev-python/simplebayes/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription lang="en">
+A memory-based, optional-persistence naïve bayesian text classifier.
+
+This work is heavily inspired by the python "redisbayes" module found here:
+[https://github.com/jart/redisbayes] and [https://pypi.python.org/pypi/redisbayes]
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hickeroar/simplebayes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simplebayes/simplebayes-1.5.7.ebuild b/dev-python/simplebayes/simplebayes-1.5.7.ebuild
new file mode 100644
index 000000000000..affaca5d7788
--- /dev/null
+++ b/dev-python/simplebayes/simplebayes-1.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="memory-based, optional-persistence naive bayesian text classifier"
+HOMEPAGE="https://github.com/hickeroar/simplebayes"
+SRC_URI="https://github.com/hickeroar/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}