summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2016-11-09 13:48:49 +0100
committerCédric Krier <cedk@gentoo.org>2016-11-09 13:49:42 +0100
commitf0362cde29477203f5e9c90c9e2253937d293060 (patch)
tree6a1fe10a4fb3816cef189aaebc33872dfeb6216d /dev-python/simpleeval/simpleeval-0.9.1.ebuild
parentmedia-gfx/geeqie: fix prefix install, bug #594712 (diff)
downloadgentoo-f0362cde29477203f5e9c90c9e2253937d293060.tar.gz
gentoo-f0362cde29477203f5e9c90c9e2253937d293060.tar.bz2
gentoo-f0362cde29477203f5e9c90c9e2253937d293060.zip
dev-python/simpleeval: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/simpleeval/simpleeval-0.9.1.ebuild')
-rw-r--r--dev-python/simpleeval/simpleeval-0.9.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/simpleeval/simpleeval-0.9.1.ebuild b/dev-python/simpleeval/simpleeval-0.9.1.ebuild
new file mode 100644
index 000000000000..cda634a793a2
--- /dev/null
+++ b/dev-python/simpleeval/simpleeval-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, safe single expression evaluator library"
+HOMEPAGE="https://github.com/danthedeckie/simpleeval"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS="README.rst"
+
+python_test() {
+ esetup.py test
+}