summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2019-12-21 16:55:37 +0100
committerCédric Krier <cedk@gentoo.org>2019-12-21 16:55:37 +0100
commit643529208c05a7b0e2c455c08036bf35f0848e00 (patch)
tree7e068946118f7dc7b8084ff0f0b6a984e984de5d /dev-python/simpleeval/simpleeval-0.9.10.ebuild
parentdev-python/phonenumbers: Version bumps (diff)
downloadgentoo-643529208c05a7b0e2c455c08036bf35f0848e00.tar.gz
gentoo-643529208c05a7b0e2c455c08036bf35f0848e00.tar.bz2
gentoo-643529208c05a7b0e2c455c08036bf35f0848e00.zip
dev-python/simpleeval: Version bumps
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Cédric Krier <cedk@gentoo.org>
Diffstat (limited to 'dev-python/simpleeval/simpleeval-0.9.10.ebuild')
-rw-r--r--dev-python/simpleeval/simpleeval-0.9.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/simpleeval/simpleeval-0.9.10.ebuild b/dev-python/simpleeval/simpleeval-0.9.10.ebuild
new file mode 100644
index 000000000000..341eb24c043a
--- /dev/null
+++ b/dev-python/simpleeval/simpleeval-0.9.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, safe single expression evaluator library"
+HOMEPAGE="https://github.com/danthedeckie/simpleeval"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS="README.rst"
+
+python_test() {
+ esetup.py test
+}