summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 20:17:18 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 20:17:18 +0200
commit874ba216c55377a2cde00944fd53ef6df9e1edfd (patch)
tree31e057c6d54cd8b08b3fff01440b0c3e3f4e7f93 /dev-python/simpleeval/simpleeval-0.9.10.ebuild
parentdev-python/simplegeneric: Enable py3.10 (diff)
downloadgentoo-874ba216c55377a2cde00944fd53ef6df9e1edfd.tar.gz
gentoo-874ba216c55377a2cde00944fd53ef6df9e1edfd.tar.bz2
gentoo-874ba216c55377a2cde00944fd53ef6df9e1edfd.zip
dev-python/simpleeval: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simpleeval/simpleeval-0.9.10.ebuild')
-rw-r--r--dev-python/simpleeval/simpleeval-0.9.10.ebuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/dev-python/simpleeval/simpleeval-0.9.10.ebuild b/dev-python/simpleeval/simpleeval-0.9.10.ebuild
index f47417669031..5bf3e2d9b30d 100644
--- a/dev-python/simpleeval/simpleeval-0.9.10.ebuild
+++ b/dev-python/simpleeval/simpleeval-0.9.10.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -13,14 +13,5 @@ SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DOCS="README.rst"
-
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py