summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simpleparse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simpleparse')
-rw-r--r--dev-python/simpleparse/Manifest1
-rw-r--r--dev-python/simpleparse/metadata.xml8
-rw-r--r--dev-python/simpleparse/simpleparse-2.1.1-r1.ebuild46
-rw-r--r--dev-python/simpleparse/simpleparse-2.1.1.ebuild54
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/simpleparse/Manifest b/dev-python/simpleparse/Manifest
new file mode 100644
index 000000000000..d3a1dfdcf795
--- /dev/null
+++ b/dev-python/simpleparse/Manifest
@@ -0,0 +1 @@
+DIST SimpleParse-2.1.1.tar.gz 207078 SHA256 2f1393790dd7b0af9775bd9c828430ffdd8bccd6227783c09e835e1aced415d9 SHA512 b0a46b8b708ba711c81f739177d7df3814dc7f0ba3a0a7e4ec9b9ade045f1ee90dfdaf76de96306c490238b901275adafbff4efdd2ab46d7a78bf9082c2da0a8 WHIRLPOOL 31a27f533942f07324684969fb8a6d687753b7f105942c7a7e660f670ed11b6009b62c56d4ddc7e2933bbb82f0b1f75a5db1d5748744c45f04f2006696a76e93
diff --git a/dev-python/simpleparse/metadata.xml b/dev-python/simpleparse/metadata.xml
new file mode 100644
index 000000000000..16b5a011d5d1
--- /dev/null
+++ b/dev-python/simpleparse/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">SimpleParse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simpleparse/simpleparse-2.1.1-r1.ebuild b/dev-python/simpleparse/simpleparse-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..0dfb017083f2
--- /dev/null
+++ b/dev-python/simpleparse/simpleparse-2.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+MY_PN="SimpleParse"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Parser Generator for mxTextTools"
+HOMEPAGE="http://simpleparse.sourceforge.net http://pypi.python.org/pypi/SimpleParse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="eGenixPublic-1.1 HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples test"
+
+S="${WORKDIR}/${MY_P}"
+
+# tests segfault, bug #454680
+RESTRICT=test
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -f {examples,tests}/__init__.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+python_test() {
+ PYTHONPATH=${BUILD_DIR}/lib python tests/test.py || die
+}
diff --git a/dev-python/simpleparse/simpleparse-2.1.1.ebuild b/dev-python/simpleparse/simpleparse-2.1.1.ebuild
new file mode 100644
index 000000000000..e1f6aa73d25c
--- /dev/null
+++ b/dev-python/simpleparse/simpleparse-2.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit distutils
+
+MY_PN="SimpleParse"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A Parser Generator for mxTextTools"
+HOMEPAGE="http://simpleparse.sourceforge.net http://pypi.python.org/pypi/SimpleParse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="eGenixPublic-1.1 HPND"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+src_prepare() {
+ distutils_src_prepare
+ rm -f {examples,tests}/__init__.py
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*):." "$(PYTHON)" tests/test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}