summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-13 05:09:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-13 06:28:39 +0100
commit5706bba0283d64e43ab48ca1a172291d9fd511be (patch)
tree36a17fa1e548c361ab642687ea8cf1ed3905b4e4 /dev-python/simpy
parentwww-client/chromium: Stabilize 119.0.6045.105 arm64, #917208 (diff)
downloadgentoo-5706bba0283d64e43ab48ca1a172291d9fd511be.tar.gz
gentoo-5706bba0283d64e43ab48ca1a172291d9fd511be.tar.bz2
gentoo-5706bba0283d64e43ab48ca1a172291d9fd511be.zip
dev-python/simpy: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simpy')
-rw-r--r--dev-python/simpy/Manifest1
-rw-r--r--dev-python/simpy/simpy-4.1.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
index 9aa4ce4c470a..70d4057cdda7 100644
--- a/dev-python/simpy/Manifest
+++ b/dev-python/simpy/Manifest
@@ -1,2 +1,3 @@
DIST simpy-4.0.2.tar.gz 410706 BLAKE2B 787da43fe29135ef3f70f286074e5b6dba50c26f50910674a290a4e9e95fe68dffca5e5308e629f8359181f9e7200938b980bdbd9d7b2c09beb30dd49069fdce SHA512 a1f9e10928930817a07ee851f3190c4aefb9c4f0538557b7cc5b0f8950ed2234878f29d1790cbf6991b78bbd73e989d7df0ed1997847eedf129fc9d1c4d1fc23
DIST simpy-4.1.0.tar.gz 407835 BLAKE2B 840815663c65e22cd8fbdf74d70fba6c5badb38e33c8506a52e163cfea2fa4f72370c4c3d53c106017c74a10a83ac15fd204f35dcffd70b29a4eb9bb4647049d SHA512 8d54e332ffd6c3ae32904a75c599b0bc33f2ac5f294c89f76632b3b2867de561169504870c89cf6f091a6674d9b9c6168f88887c628bba59e4ef2985176c8586
+DIST simpy-4.1.1.tar.gz 408997 BLAKE2B ada00417f7eb1b61eae47afd0a095c33ef493ddec48f79b2330319ff3ff2f9776cca488a5e3ec51e6c792960d2c0e649828ec1c248a19adacba6f08b713cb627 SHA512 f7e84ceb92285eb0f282892be5eba7bb6e2ba538ecb45221600c41a39aba77cfb0455c9e99ed2c688af0aca8d390f1afe9b6849b4a30be05fb5b7faec27b7253
diff --git a/dev-python/simpy/simpy-4.1.1.ebuild b/dev-python/simpy/simpy-4.1.1.ebuild
new file mode 100644
index 000000000000..e7d76b0c98c1
--- /dev/null
+++ b/dev-python/simpy/simpy-4.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="
+ https://simpy.readthedocs.io/
+ https://gitlab.com/team-simpy/simpy/
+ https://pypi.org/project/simpy/
+"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}