summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-16 05:30:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-16 05:30:02 +0100
commit5a16913524787d64ec014a64414fe376b6ddb307 (patch)
treeab32fa345327b2dcb0db3cb134d67618f2797a85 /dev-python/six
parentwww-plugins/chrome-binary-plugins: automated update (80.0.3987.53) (diff)
downloadgentoo-5a16913524787d64ec014a64414fe376b6ddb307.tar.gz
gentoo-5a16913524787d64ec014a64414fe376b6ddb307.tar.bz2
gentoo-5a16913524787d64ec014a64414fe376b6ddb307.zip
dev-python/six: Bump to 1.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/six-1.14.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index addaac0a6c48..dd03873b4a77 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -2,3 +2,4 @@ DIST six-1.10.0.tar.gz 29630 BLAKE2B 1f380dbc7a9e746b4a7909de54a58a008a73d7b6c58
DIST six-1.11.0.tar.gz 29860 BLAKE2B de4886ad9af7aa906f9eac213544c99323d74c1988d9abff96ce6fc3eea4464e577511f7c52328cbd9e6989db2128fa8d1ee57f9ce7bfc36b83ff655691b46c9 SHA512 33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24
DIST six-1.12.0.tar.gz 32725 BLAKE2B f40621076a7bb2b3b86d9f6ee49056a598e4853c6150952902053b8cfde86e562a7656b6ca3c3108f407d392cf7c1164a61b36142efd565eda909b8733c0bedb SHA512 937728372edf1e0ac13bbd706723d0de35e015c30d0ae41f789c5ed2e3669bb0db70cdc6e036ec2d437a6c4aa0d5d1e727b6d09ac34cca7e4e92e5d3b4775151
DIST six-1.13.0.tar.gz 33726 BLAKE2B 9910a72eea4adc030710b67252d01fd74ce4205bd4e0ccf662bb2bce8837853cf341c765e4f9ba2db3aaeca050dd2b1ccabefacf5c71383dad1d275326313ef6 SHA512 55eb8e23e529cb0d2ab9e7c85868e695f36c8235e914b1548eb4b9fd561e4237266bf1839457f15a9513d57a343cbf8ab809d6187499300791fd9356854fcb00
+DIST six-1.14.0.tar.gz 33857 BLAKE2B 711ef5b79118c1280c9868688869cc475668c248e6b0c2061145818842d5b4c28809d86b1388709af24f6e92fe5926ea6261f1b85c62db749f79664cbad93e4d SHA512 4dea0f4e7961e8b582d665501c65852dc3b73516a0b6f78b0888c8670f1450df58bd3eea418777f41080b842ab6c3d8633be1034bcf920192e5590d5316e2c9e
diff --git a/dev-python/six/six-1.14.0.ebuild b/dev-python/six/six-1.14.0.ebuild
new file mode 100644
index 000000000000..5b72b414e38a
--- /dev/null
+++ b/dev-python/six/six-1.14.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+distutils_enable_sphinx documentation
+distutils_enable_tests pytest