summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-15 17:01:13 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 12:00:46 +0100
commit93654f5066e9e3c5612cc5e3187463a61446aa8c (patch)
tree1966ab0f69c8a0c65883e2bbb4502267fab49c20 /dev-python/six
parentdev-python/atomicwrites: Enable py3.8, modernize (diff)
downloadgentoo-93654f5066e9e3c5612cc5e3187463a61446aa8c.tar.gz
gentoo-93654f5066e9e3c5612cc5e3187463a61446aa8c.tar.bz2
gentoo-93654f5066e9e3c5612cc5e3187463a61446aa8c.zip
dev-python/six: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.13.0.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/six/six-1.13.0.ebuild b/dev-python/six/six-1.13.0.ebuild
index 9a10d29473c0..68e1c52e8f8d 100644
--- a/dev-python/six/six-1.13.0.ebuild
+++ b/dev-python/six/six-1.13.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
inherit distutils-r1
@@ -14,26 +14,22 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
+IUSE="doc"
-DEPEND="
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx )
- test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx )"
PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+distutils_enable_tests pytest
+
python_compile_all() {
use doc && emake -C documentation html
}
-python_test() {
- pytest -vv || die "Testing failed with ${EPYTHON}"
-}
-
python_install_all() {
use doc && local HTML_DOCS=( documentation/_build/html/. )
distutils-r1_python_install_all