summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-10 14:12:54 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-10 14:19:15 +0100
commitfb11fc35bc96d2e9a88d505a49a1e6448b86b41c (patch)
tree029f436ed317c985109184cc62e506a26445b992 /dev-python/six
parentnet-p2p/airdcpp-webclient: remove old (diff)
downloadgentoo-fb11fc35bc96d2e9a88d505a49a1e6448b86b41c.tar.gz
gentoo-fb11fc35bc96d2e9a88d505a49a1e6448b86b41c.tar.bz2
gentoo-fb11fc35bc96d2e9a88d505a49a1e6448b86b41c.zip
dev-python/six: Bump to 1.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/six-1.12.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 0cc8bb77ba4b..7b3509db8865 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1,2 +1,3 @@
DIST six-1.10.0.tar.gz 29630 BLAKE2B 1f380dbc7a9e746b4a7909de54a58a008a73d7b6c582611b2481475d5d9971c936b1742ea0821c65150694914af72f43155caa54616268735a4bd2447d5b4ba4 SHA512 9a53b7bc8f7e8b358c930eaecf91cc5639176a699830153f586780c3e6d637f1bd31349a69c383574f99da19cb3a36524e7733a318f3572b27aefb69c6409c2e
DIST six-1.11.0.tar.gz 29860 BLAKE2B de4886ad9af7aa906f9eac213544c99323d74c1988d9abff96ce6fc3eea4464e577511f7c52328cbd9e6989db2128fa8d1ee57f9ce7bfc36b83ff655691b46c9 SHA512 33f246a2e987141e17e5edad9d3537cf3aba0cbdd0bc2a907ea52ce0d674b1474f29c3dd5cc26605fd960396054b189ca5f501708333cad234c223131483fe24
+DIST six-1.12.0.tar.gz 32725 BLAKE2B f40621076a7bb2b3b86d9f6ee49056a598e4853c6150952902053b8cfde86e562a7656b6ca3c3108f407d392cf7c1164a61b36142efd565eda909b8733c0bedb SHA512 937728372edf1e0ac13bbd706723d0de35e015c30d0ae41f789c5ed2e3669bb0db70cdc6e036ec2d437a6c4aa0d5d1e727b6d09ac34cca7e4e92e5d3b4775151
diff --git a/dev-python/six/six-1.12.0.ebuild b/dev-python/six/six-1.12.0.ebuild
new file mode 100644
index 000000000000..7cab04112473
--- /dev/null
+++ b/dev-python/six/six-1.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( >=dev-python/pytest-2.2.0[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/1.9.0-mapping.patch
+)
+
+python_compile_all() {
+ use doc && emake -C documentation html
+}
+
+python_test() {
+ pytest -vv || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( documentation/_build/html/. )
+ distutils-r1_python_install_all
+}