summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-07 13:55:09 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-07 13:55:41 -0700
commitb8c4ad3165847559b0e98b3c12e8ae794a6955d3 (patch)
treeeaf05ed2ebd5e085e5701d0ab7e5e94acbfad6f5 /dev-python/slackclient
parentgnome2-utils.eclass: Inherit eutils.eclass for emktemp(). (diff)
downloadgentoo-b8c4ad3165847559b0e98b3c12e8ae794a6955d3.tar.gz
gentoo-b8c4ad3165847559b0e98b3c12e8ae794a6955d3.tar.bz2
gentoo-b8c4ad3165847559b0e98b3c12e8ae794a6955d3.zip
dev-python/slackclient: build fix
Closes: https://bugs.gentoo.org/716536 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-python/slackclient')
-rw-r--r--dev-python/slackclient/slackclient-2.5.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/slackclient/slackclient-2.5.0.ebuild b/dev-python/slackclient/slackclient-2.5.0.ebuild
index c5f5e7eec92b..2af67b3adc58 100644
--- a/dev-python/slackclient/slackclient-2.5.0.ebuild
+++ b/dev-python/slackclient/slackclient-2.5.0.ebuild
@@ -21,3 +21,12 @@ RDEPEND="
"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${RDEPEND}"
+
+src_prepare() {
+ # Upstream uses pytest-runner as an extra optional target in setup.py as
+ # part of tooling to generate distfiles.
+ sed -i \
+ -e '/setup_requires=/s,"pytest-runner",,' \
+ "${S}"/setup.py || die
+ default
+}