summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-02-25 19:32:53 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-02-25 20:13:45 +0000
commit727d16b5730f00102d6161d216bd76d462342bb1 (patch)
tree0035ef91e20c2f3924ad1ba932e0c224966d70d8 /dev-python/slixmpp
parentdev-python/slixmpp: 9999: add dep on aiohttp (diff)
downloadgentoo-727d16b5730f00102d6161d216bd76d462342bb1.tar.gz
gentoo-727d16b5730f00102d6161d216bd76d462342bb1.tar.bz2
gentoo-727d16b5730f00102d6161d216bd76d462342bb1.zip
dev-python/slixmpp: add new version 1.4.2
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/slixmpp-1.4.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index bf08c4b528bc..3089e0319779 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1 +1,2 @@
DIST slixmpp-1.4.0.tar.gz 862826 BLAKE2B 940c6c66f7f98574c88da6fbfaadf7103c4469cd198e096fbad57978f5e206c53b86933a930a24a8b891415b961c4a255d4c9c25885a8bd630f5d6185486fb6e SHA512 586fa5156641d786f9e45df8e6a1a20b8cb2dc2b9baef2a0713daa9ab8a3321202fd4b31d5753cf2659cc9311a4842bee9991a7fc295e62dfd78a869d8619d20
+DIST slixmpp-1.4.2.tar.gz 864608 BLAKE2B 9689b274a9c787174248c094329ea33783627a45ef39708a611013454953de4fa8799ca5a35950a3f3ed49bebf5c56f6f2bea079bcc2a3dce7d2648bfd812371 SHA512 3b3356352af8d7ec8cca15210c0524ce0bb5e313d8c5455bec13e82aec261f6d094a99df9f08642418a0e4abea4ee1ff607e42e1c166b9be1c26534b690c330b
diff --git a/dev-python/slixmpp/slixmpp-1.4.2.ebuild b/dev-python/slixmpp/slixmpp-1.4.2.ebuild
new file mode 100644
index 000000000000..aebd4d6f2603
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}