summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-30 10:30:17 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-30 10:42:14 +0100
commitf59cfee05a3cc4ec39db15d7084af4131bbd0ec1 (patch)
tree555d03dd8e173c8958157f57b4c7244230b48513 /dev-python/snakeoil/snakeoil-9999.ebuild
parentapp-portage/gentoopm: Fix EGIT_REPO_URI (diff)
downloadgentoo-f59cfee05a3cc4ec39db15d7084af4131bbd0ec1.tar.gz
gentoo-f59cfee05a3cc4ec39db15d7084af4131bbd0ec1.tar.bz2
gentoo-f59cfee05a3cc4ec39db15d7084af4131bbd0ec1.zip
dev-python/snakeoil: Add missing mock dep, bump to EAPI 6
Diffstat (limited to 'dev-python/snakeoil/snakeoil-9999.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index f82c7fde625d..af9cbb04b486 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -20,8 +20,10 @@ HOMEPAGE="https://github.com/pkgcore/snakeoil"
LICENSE="BSD"
SLOT="0"
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
python_configure_all() {
# disable snakeoil 2to3 caching