summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-26 02:53:18 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-26 03:00:54 -0700
commit0ed7a9ac8318789581bc5335118037fc74682344 (patch)
treec7c6d5aed837367a4a484f9a9261ecee60070ad1 /dev-python/snakeoil
parentdev-vcs/mercurial: Make CFLAGS local before modification (diff)
downloadgentoo-0ed7a9ac8318789581bc5335118037fc74682344.tar.gz
gentoo-0ed7a9ac8318789581bc5335118037fc74682344.tar.bz2
gentoo-0ed7a9ac8318789581bc5335118037fc74682344.zip
dev-python/snakeoil: version bump to 0.8.7
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.7.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index a7220e8273c9..7da150dea5f5 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,2 +1,3 @@
DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
DIST snakeoil-0.8.5.tar.gz 296311 BLAKE2B d88b3f5fe299511343676ffad5a1f1efd10078f50d029b74feea66f6b6f65897e2d4dac2e96f65e0cbaae0942c5b9867fce868adf12be746c9c4ebf6f6a7f52f SHA512 d25cbc105d5c881d8e99d5c2970d524914838917a4a716d8f7269a85af0d9a067b9bb9c26a37b9eb49239f97360938bece1a1ebe87aba04340b0fe528f44dc4b
+DIST snakeoil-0.8.7.tar.gz 296593 BLAKE2B ecc745d63e50c5393ee2cf2bea62a0f356b5aa5432f4b6ca2578c7324139592ad38aaf71336715342298da9a2b8bc8c90efab3f9512835b17b4af56632997bfe SHA512 010bbaa08f84ce59f20324ae86af4ad71c167442557934e31fc2040e3ced8d2ce0f1657272057d06e9fd1c22fd8ec89ad3233f24443ace4861121319f2772679
diff --git a/dev-python/snakeoil/snakeoil-0.8.7.ebuild b/dev-python/snakeoil/snakeoil-0.8.7.ebuild
new file mode 100644
index 000000000000..424cd085a42c
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.8.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}