summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-19 09:03:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-19 09:05:42 +0100
commit29230faee2f8dbbd64751b8fc8e065874798236d (patch)
tree2f1917640d7bbd923384b2b894e359606b006557 /dev-python/snakeoil
parentapp-emulation/lxd: fix building with go-1.16 (diff)
downloadgentoo-29230faee2f8dbbd64751b8fc8e065874798236d.tar.gz
gentoo-29230faee2f8dbbd64751b8fc8e065874798236d.tar.bz2
gentoo-29230faee2f8dbbd64751b8fc8e065874798236d.zip
dev-python/snakeoil: Add lazy-object-proxy dep to 0.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/snakeoil-0.9.2-r1.ebuild (renamed from dev-python/snakeoil/snakeoil-0.9.2.ebuild)5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.9.2.ebuild b/dev-python/snakeoil/snakeoil-0.9.2-r1.ebuild
index 0a7822decd00..3c166435f1c2 100644
--- a/dev-python/snakeoil/snakeoil-0.9.2.ebuild
+++ b/dev-python/snakeoil/snakeoil-0.9.2-r1.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi
@@ -20,6 +20,9 @@ HOMEPAGE="https://github.com/pkgcore/snakeoil"
LICENSE="BSD BSD-2 MIT"
SLOT="0"
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]"
+
[[ ${PV} == 9999 ]] && BDEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
distutils_enable_tests pytest