summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-09-13 11:30:18 -0600
committerTim Harder <radhermit@gentoo.org>2019-09-13 11:45:33 -0600
commit9e89f32904a1ae3eccfe99bc7f59ad86982ce786 (patch)
tree03c4c2c93899a3a6d4206e3b090ed0f0688c3a41 /dev-python/snakeoil
parentdev-lang/ruby: arm stable wrt bug #688976 (diff)
downloadgentoo-9e89f32904a1ae3eccfe99bc7f59ad86982ce786.tar.gz
gentoo-9e89f32904a1ae3eccfe99bc7f59ad86982ce786.tar.bz2
gentoo-9e89f32904a1ae3eccfe99bc7f59ad86982ce786.zip
dev-python/snakeoil: version bump to 0.8.3
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.3.ebuild34
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild2
3 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 7d76d270e737..921c01850999 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,3 +1,4 @@
DIST snakeoil-0.7.5.tar.gz 303270 BLAKE2B 66d00cf50c8efd73d765904b9c7e8ba725caef9608e68f5707ddc09358507fe64214af73b333ec5bee2ef950d8dbad474cb5d9e4412757bc3c82d75909f6fc23 SHA512 b9f6efce2e3f5df83248b1faa84493aa11d8a08935e3991a56daace96e0de39dd5c7d25a69a4394f7ba163de78ed56a2619ef64c33114128fc02052d676a86a5
DIST snakeoil-0.8.1.tar.gz 296997 BLAKE2B 0eef059c73f6f62ddf67ec3a76d48bc01383f5993236f43cbdef54f6c9e9f818b6065f266df2c8646963f74f8cf3b549ae8e3407cd3a38d38de95d7b84dcfb1b SHA512 70f379d06b000abd193db41fdd720161a22537320a538b6441a9cde86fe0755ec68ab393aa8442e035b134f88e20ddfd4e194961b53f7cfa7a857ec12bf7437c
DIST snakeoil-0.8.2.tar.gz 297135 BLAKE2B fab94a4f085756228f4a74dc966ef34c94d0c33dba50e7d4d2f3a1417ca84e337a15688b171930af04a3ec3f55980025cc0c078a9b16670fb11d5f546077bca6 SHA512 401135f8b12321db5f65fb1431e8145ba1691ddc83ad106fef22beefeee5212e13fd1f9726b40267553dca46955ed1cd4dda0d3aa76cf25882bf0fc8017bba01
+DIST snakeoil-0.8.3.tar.gz 297775 BLAKE2B b08c2c1bfea98e391b1da59ba0fd28e2187a83291c9c665f1394ed2b985b959ff5f5328db6a379d0d29e0fd86c82f965c40280f38ef5064727d4d9b173905c42 SHA512 d17a410f1684bb0398a115bbe6539895ea84a2ff7a1f3d05a66937f5f83783f2c503e985839d26f03565e960040a10e1985c43bb7376feda7c088ae279838be9
diff --git a/dev-python/snakeoil/snakeoil-0.8.3.ebuild b/dev-python/snakeoil/snakeoil-0.8.3.ebuild
new file mode 100644
index 000000000000..186d88f724ac
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.8.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index e85e66b9b7a0..186d88f724ac 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -17,7 +17,7 @@ fi
DESCRIPTION="misc common functionality and useful optimizations"
HOMEPAGE="https://github.com/pkgcore/snakeoil"
-LICENSE="BSD"
+LICENSE="BSD BSD-2 MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"