summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 17:01:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 18:10:57 +0200
commitc3400aa9f9b8295a5b2fcd95952b66d6fcd93c94 (patch)
tree8a5292fbc7b0c235a512c5328ec933e68e5f1452 /dev-python/sniffio
parentdev-db/sqlite: Stabilize 3.38.2 ppc64, #844046 (diff)
downloadgentoo-c3400aa9f9b8295a5b2fcd95952b66d6fcd93c94.tar.gz
gentoo-c3400aa9f9b8295a5b2fcd95952b66d6fcd93c94.tar.bz2
gentoo-c3400aa9f9b8295a5b2fcd95952b66d6fcd93c94.zip
dev-python/sniffio: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/sniffio-1.2.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sniffio/sniffio-1.2.0-r1.ebuild b/dev-python/sniffio/sniffio-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..08c92e236b7e
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.2.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio/
+ https://pypi.org/project/sniffio/
+"
+SRC_URI="
+ https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)