summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 21:44:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:50 +0300
commitd0635b06164a98ddb5b587586ebeb67595a0aee6 (patch)
treecadda004ae5185a59b5ebae30da81f6fcbbefc17 /dev-python/sniffio
parentdev-python/keyring: add 23.9.0 (diff)
downloadgentoo-d0635b06164a98ddb5b587586ebeb67595a0aee6.tar.gz
gentoo-d0635b06164a98ddb5b587586ebeb67595a0aee6.tar.bz2
gentoo-d0635b06164a98ddb5b587586ebeb67595a0aee6.zip
dev-python/sniffio: add 1.3.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/Manifest1
-rw-r--r--dev-python/sniffio/sniffio-1.3.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sniffio/Manifest b/dev-python/sniffio/Manifest
index d096430d8bf3..b2afe8788f9f 100644
--- a/dev-python/sniffio/Manifest
+++ b/dev-python/sniffio/Manifest
@@ -1 +1,2 @@
DIST sniffio-1.2.0.gh.tar.gz 17335 BLAKE2B 0d67baa18702ac38932680bdc741c87ee0a31342cc752c1463a7f90720ea0ebf6d62ef682a042c58e8fe96456e1461638e0f02c6f60da5f5e0d07464be27a4a3 SHA512 8e1dd2bb6fc22ee5824adfffe688ff0621b8c1ef5daea594dedce13d5e04a498e05816bb32e9bbed206a653a330ff710df57c888ddcff00a6254eafddc538273
+DIST sniffio-1.3.0.gh.tar.gz 16867 BLAKE2B 44ab59d7477055aeaa0b08983094d8d12493edd5ded6ebd8e1bb048fbb2024325473dc37ebb5f66a10d8275b4e68b8c7f8dfb26088dc30c97a29d9f002fbc667 SHA512 3a9584eea20f5a69958f206fad9f01ef7fc40735f48a6cfaa11ba6eea1e7b8cc8c8053416595fe23276e162b0ab5dd6a41fb30bd9f7994f03b3d3242d5b40ef6
diff --git a/dev-python/sniffio/sniffio-1.3.0.ebuild b/dev-python/sniffio/sniffio-1.3.0.ebuild
new file mode 100644
index 000000000000..d22e05c4e1b3
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio/
+ https://pypi.org/project/sniffio/
+"
+SRC_URI="
+ https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+)