summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/snowballstemmer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/snowballstemmer')
-rw-r--r--dev-python/snowballstemmer/Manifest1
-rw-r--r--dev-python/snowballstemmer/metadata.xml9
-rw-r--r--dev-python/snowballstemmer/snowballstemmer-1.2.0.ebuild20
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/snowballstemmer/Manifest b/dev-python/snowballstemmer/Manifest
new file mode 100644
index 000000000000..07f34b9d542c
--- /dev/null
+++ b/dev-python/snowballstemmer/Manifest
@@ -0,0 +1 @@
+DIST snowballstemmer-1.2.0.tar.gz 49639 SHA256 6d54f350e7a0e48903a4e3b6b2cabd1b43e23765fbc975065402893692954191 SHA512 3359657867b9478bb58e6cc67a08212a490d5af07fed7098871b1e6a59def0031bd0c2a846cc9a0d70c94c64ba4d2ccb2f41afedde61d4a7235d26f68374bd02 WHIRLPOOL bf84c482c35ef9e121f13865e43bfc4bcc6ed13959069d5da4f047309986795bcaf09a5cecaf16361d8ea8365f9bf26ca6987574b7ad2cc25572d0992946a44b
diff --git a/dev-python/snowballstemmer/metadata.xml b/dev-python/snowballstemmer/metadata.xml
new file mode 100644
index 000000000000..b37f5be03c6f
--- /dev/null
+++ b/dev-python/snowballstemmer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">snowballstemmer</remote-id>
+ <remote-id type="github">shibukawa/snowball_py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/snowballstemmer/snowballstemmer-1.2.0.ebuild b/dev-python/snowballstemmer/snowballstemmer-1.2.0.ebuild
new file mode 100644
index 000000000000..b4dc132b11b1
--- /dev/null
+++ b/dev-python/snowballstemmer/snowballstemmer-1.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Stemmer algorithms generated from Snowball algorithms"
+HOMEPAGE="https://github.com/shibukawa/snowball_py https://pypi.python.org/pypi/snowballstemmer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"