summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-09-10 17:19:47 -0700
committerZac Medico <zmedico@gentoo.org>2018-09-10 17:19:47 -0700
commitf1ba2e566a8cd887f29b03f409a63854eaf5d106 (patch)
tree2b92597e06e819c66f2c6f83a67905bdd38cd4ad /dev-python/socketio-client-nexus/socketio-client-nexus-0.7.6.ebuild
parentnet-vpn/tor: drop older version (diff)
downloadgentoo-f1ba2e566a8cd887f29b03f409a63854eaf5d106.tar.gz
gentoo-f1ba2e566a8cd887f29b03f409a63854eaf5d106.tar.bz2
gentoo-f1ba2e566a8cd887f29b03f409a63854eaf5d106.zip
dev-python/socketio-client-nexus: new package
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/socketio-client-nexus/socketio-client-nexus-0.7.6.ebuild')
-rw-r--r--dev-python/socketio-client-nexus/socketio-client-nexus-0.7.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/socketio-client-nexus/socketio-client-nexus-0.7.6.ebuild b/dev-python/socketio-client-nexus/socketio-client-nexus-0.7.6.ebuild
new file mode 100644
index 000000000000..1046c7e46269
--- /dev/null
+++ b/dev-python/socketio-client-nexus/socketio-client-nexus-0.7.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="socketIO-client-nexus"
+DESCRIPTION="A socket.io 2.x client library for Python"
+HOMEPAGE="https://github.com/nexus-devs/socketIO-client-2.0.3/ https://pypi.org/project/socketIO-client-nexus/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"