summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2016-11-28 19:46:24 -0600
committerDenis Dupeyron <calchan@gentoo.org>2016-11-28 19:50:23 -0600
commiteca7e499735c9155a53bc3bfa282b17a5a6354d7 (patch)
treea3f49ab768021d6786441fd27eb34fc3fcb0bf6a /dev-python/spark-parser/spark-parser-1.5.1-r1.ebuild
parentwww-client/firefox : 50.0.1 security bump, bug #601142 (diff)
downloadgentoo-eca7e499735c9155a53bc3bfa282b17a5a6354d7.tar.gz
gentoo-eca7e499735c9155a53bc3bfa282b17a5a6354d7.tar.bz2
gentoo-eca7e499735c9155a53bc3bfa282b17a5a6354d7.zip
dev-python/spark-parser-1.5.1: sed in python_prepare_all is no longer needed for tests
Diffstat (limited to 'dev-python/spark-parser/spark-parser-1.5.1-r1.ebuild')
-rw-r--r--dev-python/spark-parser/spark-parser-1.5.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/spark-parser/spark-parser-1.5.1-r1.ebuild b/dev-python/spark-parser/spark-parser-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..9ca7566496ba
--- /dev/null
+++ b/dev-python/spark-parser/spark-parser-1.5.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+MY_PN="spark_parser"
+
+DESCRIPTION="An Early-Algorithm Context-free grammar Parser"
+HOMEPAGE="https://github.com/rocky/python-spark/ https://pypi.python.org/pypi/spark_parser"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ emake check
+}