summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-26 12:55:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-26 16:11:28 +0200
commit22599543b5b1e447a217fd5b7c52debbbf161b8a (patch)
tree314f60527cff0f8172aa9b73de7514bfdb1d7971 /dev-python/sphinx-autoapi
parentdev-python/imageio: Bump to 2.20.0 (diff)
downloadgentoo-22599543b5b1e447a217fd5b7c52debbbf161b8a.tar.gz
gentoo-22599543b5b1e447a217fd5b7c52debbbf161b8a.tar.bz2
gentoo-22599543b5b1e447a217fd5b7c52debbbf161b8a.zip
dev-python/sphinx-autoapi: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autoapi')
-rw-r--r--dev-python/sphinx-autoapi/Manifest1
-rw-r--r--dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinx-autoapi/Manifest b/dev-python/sphinx-autoapi/Manifest
index 8f4b84c9d6c4..1c64975e41d0 100644
--- a/dev-python/sphinx-autoapi/Manifest
+++ b/dev-python/sphinx-autoapi/Manifest
@@ -1 +1,2 @@
DIST sphinx-autoapi-1.8.4.tar.gz 83541 BLAKE2B 05d706fda6da4aea55e535a995ef01dc54269fa8e452c51c9bf2cec2e596ccec20191b8cb3c0cde1b93daa4f5d85074a293c9fd449d99d3c494ba20c6cee2df8 SHA512 10b4d87e1046ad372a3491006cd4bece8334fc398025f98654781c83ee200045d707f3293a031f8cf0abe5d20a111e7ded864f2b6deffe5222b331ca8c9b688b
+DIST sphinx-autoapi-1.9.0.gh.tar.gz 84730 BLAKE2B 31547c0dee076736d65867d9856e713581c440d2b1f01b7ebcbe09b31a7bf2979346bcbe18d6064fd5656b7d7dab9149c67fe79f0db7e5757c2581370c11a8cd SHA512 f098f474d9821c974c2ede77de30f3317c87cb87ec00b7a1c021add1d07a1ed59fa3b4165edf2b7f5165004ba9c717394962154098bc89b52989d0e604c542f1
diff --git a/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild b/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
new file mode 100644
index 000000000000..3a7bbebfd20c
--- /dev/null
+++ b/dev-python/sphinx-autoapi/sphinx-autoapi-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A new approach to API documentation in Sphinx"
+HOMEPAGE="
+ https://sphinx-autoapi.readthedocs.io/
+ https://github.com/readthedocs/sphinx-autoapi/
+ https://pypi.org/project/sphinx-autoapi/
+"
+SRC_URI="
+ https://github.com/readthedocs/sphinx-autoapi/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/astroid[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.rst )
+
+# Test requires pypi download w/ internet: https://github.com/readthedocs/sphinx-autoapi/issues/329
+EPYTEST_DESELECT=(
+ tests/test_integration.py::TestExtensionErrors::test_extension_setup_errors[dotnetexample-override_conf2-AutoAPI
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc