summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-08 22:00:18 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-08 22:17:54 +0300
commit288f3da076cef8f8743f5c4cee21b8286b5b3acd (patch)
treecec0fee4060954f96470c21d2a85ff97fbdd3e7a /dev-python/sphinx-autodoc-typehints
parentdev-python/sqlalchemy: add 1.4.40 (diff)
downloadgentoo-288f3da076cef8f8743f5c4cee21b8286b5b3acd.tar.gz
gentoo-288f3da076cef8f8743f5c4cee21b8286b5b3acd.tar.bz2
gentoo-288f3da076cef8f8743f5c4cee21b8286b5b3acd.zip
dev-python/sphinx-autodoc-typehints: add 1.19.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 3dd2ef052d1e..7e73c2d3778e 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,3 +1,4 @@
DIST sphinx-autodoc-typehints-1.18.3.gh.tar.gz 26457 BLAKE2B 343a6ffcbca40f28a66c67266431f3a9b2292bd0d991de4287b9adf9e02b7d8fb24094646caa55790f32cd9081abca525f310367335d60fa1b7ea3bc9623bb1c SHA512 549bdfad8f5c07f5edb1c6cdeaff39df22cc7bfa475c70b5c54ff46b311d14c9f3682bf68663d852b95ebff8fd1b71038fc077495d99d870ae2efbf72ec99a42
DIST sphinx-autodoc-typehints-1.19.0.gh.tar.gz 26950 BLAKE2B 4e530c0b16500d8489bed7f50518b1bc30fdc824d41eb6cc66786096c09c910deb92ac580438395e3b71fd2d3b64690986cb035ff2d784e26918a42bdc73d8fc SHA512 d9459aca1091da0fa446d7ce72ef83c172775b66081d87431c14fd9cfda42770dbd08450ff193e3accffe0eb11efde22804e4ffff20a8e0e9072a05bc34a99e9
DIST sphinx-autodoc-typehints-1.19.1.gh.tar.gz 26942 BLAKE2B a2b16292eeaf87cb4879bf54727874952b61b596c6226679ba472a0e138fc09f82aaeffabf0f83eca56d2b2df609ed0355e1f3ab5dffd8119c1eccc755bbb16d SHA512 16227301bb0e3035163734c852068d7d06ff03c1e577963bdbcffb5b24b1ededc7feb16025fdcf8611182bdbbc7b071288f5d1d42cb0115bef6f9652898e3a8a
+DIST sphinx-autodoc-typehints-1.19.2.gh.tar.gz 26983 BLAKE2B 694edbf94bac05670adad992cfdc7e1146228af7b888a97c4f8e2394623ef3e42251ba0f3c22985517b2a251996cc41a305ea5497b2369363bc00d4bb3d24da7 SHA512 c35c7ed3f0698651be5ba4dd2232912d1f6d9d30e08153527df3fe16001266abc80cd1b11e3a41ccf92140c6baea98105e9bccd9466e65664dcf008f9a944634
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.2.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.2.ebuild
new file mode 100644
index 000000000000..9eca6f1f4db5
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-4.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.1.1[${PYTHON_USEDEP}]
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}