summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-16 14:52:16 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-16 14:52:16 +0100
commit3111f83f1666b31e70947a4d91b82f77c8c0249a (patch)
tree84f2ec4c7d7a8462d75811f2531efb5598261626 /dev-python/sphinx-autodoc-typehints
parentdev-lang/gnat-gpl: use architecture specific name for bootstrap (diff)
downloadgentoo-3111f83f1666b31e70947a4d91b82f77c8c0249a.tar.gz
gentoo-3111f83f1666b31e70947a4d91b82f77c8c0249a.tar.bz2
gentoo-3111f83f1666b31e70947a4d91b82f77c8c0249a.zip
dev-python/sphinx-autodoc-typehints: add 1.19.5
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 5bb55a4989e4..2d06f9bacbc6 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx-autodoc-typehints-1.19.4.gh.tar.gz 27724 BLAKE2B 5d22561515286a3530a86dad5cf80f0f66068ee50e10a60513dc66bb17be9a8aabb10fe9a35dd6cbeddc6eb78c2403e8f880cbed01e048c5bb3ce48716ff6bdc SHA512 d36a8b3f32dfb6204a248b91f20882b97efa9aa746cd9eeb445945de165511ddce4f9d3cc63799a5f9acc5b2fa6a4352eb7205e679b8937138a12cc462c94056
+DIST sphinx-autodoc-typehints-1.19.5.gh.tar.gz 27758 BLAKE2B f73b0afa3656949f5aa14c8055020bccd81ff5f81df6dbf7c95d3656597d1e2e12918f77c6af56afb5c3ec28680e270aaa81c3d149b5427872dd8844bcaec495 SHA512 90cc5bb81e0a76ea3e476e3821299573ea0deaef0e007d2f83e0ff442db34bccf6e1078a4e06243bf19c8ee964477b924369ebbffb6ab4aa1cd673b16b0c79b2
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.5.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.5.ebuild
new file mode 100644
index 000000000000..4c5d80c086f7
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}