summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-27 03:42:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-27 04:03:54 +0200
commita1382cdc80a66413cc35b9880a92c4de3a6cd62c (patch)
tree5881b0e04b5e199c7023437dfaa03f559146d2fc /dev-python/sphinx-autodoc-typehints
parentnet-misc/electrum: Bump to 4.3.2 (diff)
downloadgentoo-a1382cdc80a66413cc35b9880a92c4de3a6cd62c.tar.gz
gentoo-a1382cdc80a66413cc35b9880a92c4de3a6cd62c.tar.bz2
gentoo-a1382cdc80a66413cc35b9880a92c4de3a6cd62c.zip
dev-python/sphinx-autodoc-typehints: Bump to 1.19.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index a23882d0e15c..876de1377bf8 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx-autodoc-typehints-1.19.2.gh.tar.gz 26983 BLAKE2B 694edbf94bac05670adad992cfdc7e1146228af7b888a97c4f8e2394623ef3e42251ba0f3c22985517b2a251996cc41a305ea5497b2369363bc00d4bb3d24da7 SHA512 c35c7ed3f0698651be5ba4dd2232912d1f6d9d30e08153527df3fe16001266abc80cd1b11e3a41ccf92140c6baea98105e9bccd9466e65664dcf008f9a944634
+DIST sphinx-autodoc-typehints-1.19.3.gh.tar.gz 27694 BLAKE2B c1528fa4d4e055dab723bfc40baea591a201546abdccbb81e7dd9ada8620ea74d7371f9c47a8ef310f57934de95b5c295939fa9c095492e02606ca9828bf921d SHA512 fba1b5b39b9c8556ffa75e1a9d2427623bb8ee6f412b78c293c77b248b81d73f624beca9c155279147951510daed7cf5a5120e714efbcce4d62251f74f0924a4
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.3.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.3.ebuild
new file mode 100644
index 000000000000..b61995da51f2
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-5.2.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/sphobjinv-2.2.2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}