summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-29 12:42:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-29 13:12:04 +0300
commitc618ec48b1bf0015d91a48929204222c99648133 (patch)
treefd366e1e0418a03825bd3680c460aee3859da759 /dev-python/sphinx-autodoc-typehints
parentdev-python/sphinxcontrib-doxylink: add 1.12.1 (diff)
downloadgentoo-c618ec48b1bf0015d91a48929204222c99648133.tar.gz
gentoo-c618ec48b1bf0015d91a48929204222c99648133.tar.bz2
gentoo-c618ec48b1bf0015d91a48929204222c99648133.zip
dev-python/sphinx-autodoc-typehints: add 1.19.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 969c6dc88d2d..ceb71bfa6118 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1 +1,2 @@
DIST sphinx-autodoc-typehints-1.18.3.gh.tar.gz 26457 BLAKE2B 343a6ffcbca40f28a66c67266431f3a9b2292bd0d991de4287b9adf9e02b7d8fb24094646caa55790f32cd9081abca525f310367335d60fa1b7ea3bc9623bb1c SHA512 549bdfad8f5c07f5edb1c6cdeaff39df22cc7bfa475c70b5c54ff46b311d14c9f3682bf68663d852b95ebff8fd1b71038fc077495d99d870ae2efbf72ec99a42
+DIST sphinx-autodoc-typehints-1.19.0.gh.tar.gz 26950 BLAKE2B 4e530c0b16500d8489bed7f50518b1bc30fdc824d41eb6cc66786096c09c910deb92ac580438395e3b71fd2d3b64690986cb035ff2d784e26918a42bdc73d8fc SHA512 d9459aca1091da0fa446d7ce72ef83c172775b66081d87431c14fd9cfda42770dbd08450ff193e3accffe0eb11efde22804e4ffff20a8e0e9072a05bc34a99e9
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild
new file mode 100644
index 000000000000..9eca6f1f4db5
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-1.19.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+SRC_URI="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/sphinx-4.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nptyping-2.1.1[${PYTHON_USEDEP}]
+ dev-python/sphobjinv[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}