summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-03 10:55:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-03 11:16:30 +0300
commit679d806c3cf343e60699eb5f44eaa288b25adea2 (patch)
treef78f15657b3c058161659efee3d5e2be87b0e38e /dev-python/sphinx-jinja
parentapp-misc/pdfpc: add missing deps to 4.5.0 (diff)
downloadgentoo-679d806c3cf343e60699eb5f44eaa288b25adea2.tar.gz
gentoo-679d806c3cf343e60699eb5f44eaa288b25adea2.tar.bz2
gentoo-679d806c3cf343e60699eb5f44eaa288b25adea2.zip
dev-python/sphinx-jinja: add 1.1.0, enable py3.10, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-jinja')
-rw-r--r--dev-python/sphinx-jinja/Manifest1
-rw-r--r--dev-python/sphinx-jinja/sphinx-jinja-1.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinx-jinja/Manifest b/dev-python/sphinx-jinja/Manifest
index 305af2c777e5..97f68f2876c6 100644
--- a/dev-python/sphinx-jinja/Manifest
+++ b/dev-python/sphinx-jinja/Manifest
@@ -1 +1,2 @@
DIST sphinx-jinja-0.3.0.tar.gz 7035 BLAKE2B a43c2ab6c1f0178987ccf9f69acbf0b50974573b83d0503e7888a56bf024e519ad69e3ac6ec9b8d27d7e01e9482008b6579c6892ce114124c0ef12ef456c887c SHA512 b39211a0013db020112c865335811317699e7ade734bfd9bb24f51934df4652f0560b81f5e253fc663fbd8a269fd962ef2bfd6dc96eab12a397a538e758cddfd
+DIST sphinx-jinja-1.1.0.tar.gz 7306 BLAKE2B 17b8df65f32e0b39eeed406b9bd71974a2b4399154b6d3bf13d9011c0d415b856345ec2fffff8fed39f893b7adb5fa1c012ebf80319ac6af74739e7fe9372229 SHA512 acbe1c2f2044b8e202db60a9964c509a33206c113ca2833dc43bb4849bc91e26b0c84959d8c8f2e5331c33c2e9de73c0348a3841740a5b7d260a43bf4876949f
diff --git a/dev-python/sphinx-jinja/sphinx-jinja-1.1.0.ebuild b/dev-python/sphinx-jinja/sphinx-jinja-1.1.0.ebuild
new file mode 100644
index 000000000000..49aca906f001
--- /dev/null
+++ b/dev-python/sphinx-jinja/sphinx-jinja-1.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension to include jinja based templates into a sphinx doc"
+HOMEPAGE="https://github.com/tardyp/sphinx-jinja https://pypi.org/project/sphinx-jinja/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -e "s/import urllib/import urllib.request as urllib/" \
+ -i sphinxcontrib/jinja.py || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}