summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-09-02 20:52:07 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:23 +0300
commit7de47c97caff32b5fc036d5f86c0e18051770046 (patch)
treef9184361ea5701f1e54ddeafb2876f6db8312a6a /dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4.ebuild
parentdev-python/spyder-kernels: version bump 1.9.4 (diff)
downloadgentoo-7de47c97caff32b5fc036d5f86c0e18051770046.tar.gz
gentoo-7de47c97caff32b5fc036d5f86c0e18051770046.tar.bz2
gentoo-7de47c97caff32b5fc036d5f86c0e18051770046.zip
dev-python/sphinx-multiversion: Add support for multiple versions
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4.ebuild')
-rw-r--r--dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4.ebuild b/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4.ebuild
new file mode 100644
index 000000000000..eb17e4c52eac
--- /dev/null
+++ b/dev-python/sphinx-multiversion/sphinx-multiversion-0.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Add support for multiple versions to sphinx"
+HOMEPAGE="https://github.com/Holzhaus/sphinx-multiversion"
+SRC_URI="https://github.com/Holzhaus/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/alabaster