summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-03 23:48:46 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-04 00:01:12 +0200
commit31c59c563c8badce61527e6958fa089ee240a81a (patch)
treeef0fbedb5c6a9cd58d7d0f9ad82b29f73cc6704a /dev-python/sphinx-panels
parentdev-python/cfn-python-lint: Bump to 0.50.0 (diff)
downloadgentoo-31c59c563c8badce61527e6958fa089ee240a81a.tar.gz
gentoo-31c59c563c8badce61527e6958fa089ee240a81a.tar.bz2
gentoo-31c59c563c8badce61527e6958fa089ee240a81a.zip
dev-python/sphinx-panels: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-panels')
-rw-r--r--dev-python/sphinx-panels/Manifest1
-rw-r--r--dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sphinx-panels/Manifest b/dev-python/sphinx-panels/Manifest
index 94dd6b5569a6..a1ec7508ccc3 100644
--- a/dev-python/sphinx-panels/Manifest
+++ b/dev-python/sphinx-panels/Manifest
@@ -1 +1,2 @@
DIST sphinx-panels-0.5.2.tar.gz 400415 BLAKE2B af103b3a10032590def4b41c650e9023fe94ec6e2fe764a09237cad4d928b1ff429a7a385770f2d07724897413f001ae4037c6e8638b3a9c1d63362c361fd999 SHA512 6d4eb566623543d0553790136e420e3f3a23e06f38b64642e2bb535a5401a954719135a9af89b3655190aebcd35024cecd40b887e7b2bb1394a2a575447316c0
+DIST sphinx-panels-0.6.0.tar.gz 400548 BLAKE2B 685b241ffe839face392950ccaa5c00d5613ee4076a4f8d62fdff32158f2d02c444375b7f656a89d4712f8bf895b937ff9fe650cab98670f03b0c4d75e545f97 SHA512 74064538ff8cd1c7c44b5daeda272217618ed33394694883046972b4262d503e1426e7573d8b49040d4b426651377b89fd4ad2a085f1e62827e7ef51e6912e5f
diff --git a/dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild b/dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild
new file mode 100644
index 000000000000..3476ddafa385
--- /dev/null
+++ b/dev-python/sphinx-panels/sphinx-panels-0.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for creating panels in a grid layout"
+HOMEPAGE="https://github.com/executablebooks/sphinx-panels"
+SRC_URI="https://github.com/executablebooks/sphinx-panels/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/pytest-regressions[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme