summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 06:23:12 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-24 07:16:26 +0200
commitf4e54f7b63d7cfb42f85626cea9b7e1e7fe55ee5 (patch)
treee87bb87fcd22f0094724c61e3d9b8e9dcb07bd85 /dev-python/sphinx-pytest
parentapp-admin/awscli: Bump to 1.25.16 (diff)
downloadgentoo-f4e54f7b63d7cfb42f85626cea9b7e1e7fe55ee5.tar.gz
gentoo-f4e54f7b63d7cfb42f85626cea9b7e1e7fe55ee5.tar.bz2
gentoo-f4e54f7b63d7cfb42f85626cea9b7e1e7fe55ee5.zip
dev-python/sphinx-pytest: Bump to 0.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-pytest')
-rw-r--r--dev-python/sphinx-pytest/Manifest1
-rw-r--r--dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinx-pytest/Manifest b/dev-python/sphinx-pytest/Manifest
index 5811268458d8..b3a82425fd6e 100644
--- a/dev-python/sphinx-pytest/Manifest
+++ b/dev-python/sphinx-pytest/Manifest
@@ -1 +1,2 @@
DIST sphinx-pytest-0.0.3.gh.tar.gz 5898 BLAKE2B 08fe98b3add1d76454c30a11f4d82bd04123e44fa5c28d420401014e5aef11354541781c0ba43a5d95c0c6fd35b12742ecf630005faae68125f5c6686c19ef59 SHA512 f1ee23fd5f320b5b4ac48638d509963638322374136d98516a17075e0d5b05cfa64107541c80daad424dfcd9e769a95dd5aa8d7f86d8ded214c9a3cdf901cf1f
+DIST sphinx-pytest-0.0.4.gh.tar.gz 6196 BLAKE2B 24b8be165a58b15a845f076b33fb7a2525afefa7fd8bf836ac679280d271716ff02bf3adfa9b485507bc3f8a6cb91b0458a0b5bdb62bf8920c09eb20468e8949 SHA512 25bf3fafddf02aed8b2478dc2beafa251027652d03f31bbac67eb98913e359f9497a9018561aff0fdaf568ece4bcfa15705dcfa2fd3734f4db6c613b24d6a568
diff --git a/dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild b/dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild
new file mode 100644
index 000000000000..5dda95b0b5eb
--- /dev/null
+++ b/dev-python/sphinx-pytest/sphinx-pytest-0.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpful pytest fixtures for Sphinx extensions"
+HOMEPAGE="
+ https://github.com/chrisjsewell/sphinx-pytest/
+ https://pypi.org/project/sphinx_pytest/
+"
+SRC_URI="
+ https://github.com/chrisjsewell/sphinx-pytest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest