summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-16 13:27:39 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-16 13:27:39 +0200
commit2864b10d3da3d29d8c61524dc792ec359fffcbd0 (patch)
tree7227bad0db6c2c3c93d5128554190902ebd9b472 /dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
parentdev-python/httpretty: Add python3_6 (diff)
downloadgentoo-2864b10d3da3d29d8c61524dc792ec359fffcbd0.tar.gz
gentoo-2864b10d3da3d29d8c61524dc792ec359fffcbd0.tar.bz2
gentoo-2864b10d3da3d29d8c61524dc792ec359fffcbd0.zip
dev-python/sphinx-testing: Initial version
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild')
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
new file mode 100644
index 000000000000..71a84edcf47b
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-0.7.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*') )"
+
+python_test() {
+ nosetests || die
+}