summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 14:33:33 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 14:33:40 +0200
commit1e6eef41e5eebe54f36a64914f95d0e653b2b7cf (patch)
tree9bc6bde027fb5d7d81c94ce39962b53b664c5184 /dev-python/sphinx
parentdev-db/postgresql: sparc stable wrt bug #562586 (diff)
downloadgentoo-1e6eef41e5eebe54f36a64914f95d0e653b2b7cf.tar.gz
gentoo-1e6eef41e5eebe54f36a64914f95d0e653b2b7cf.tar.bz2
gentoo-1e6eef41e5eebe54f36a64914f95d0e653b2b7cf.zip
dev-python/sphinx: Move dev-python/sphinx_rtd_theme to PDEPEND to break circular deps
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/sphinx-1.3.1-r1.ebuild2
-rw-r--r--dev-python/sphinx/sphinx-1.3.1.ebuild11
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/sphinx/sphinx-1.3.1-r1.ebuild b/dev-python/sphinx/sphinx-1.3.1-r1.ebuild
index 94c68d4aa0be..6a00156bc5ed 100644
--- a/dev-python/sphinx/sphinx-1.3.1-r1.ebuild
+++ b/dev-python/sphinx/sphinx-1.3.1-r1.ebuild
@@ -28,7 +28,6 @@ RDEPEND="
>=dev-python/six-1.4[${PYTHON_USEDEP}]
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
=dev-python/alabaster-0.7*[${PYTHON_USEDEP}]
- =dev-python/sphinx_rtd_theme-0.1*[${PYTHON_USEDEP}]
>=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
latex? (
dev-texlive/texlive-latexextra
@@ -39,6 +38,7 @@ DEPEND="${DEPEND}
dev-python/nose[${PYTHON_USEDEP}]
$(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
)"
+PDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/sphinx/sphinx-1.3.1.ebuild b/dev-python/sphinx/sphinx-1.3.1.ebuild
index 3c4d93923c45..48c79764279e 100644
--- a/dev-python/sphinx/sphinx-1.3.1.ebuild
+++ b/dev-python/sphinx/sphinx-1.3.1.ebuild
@@ -20,22 +20,25 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc64 ~x86"
IUSE="doc latex test"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/docutils-0.11[${PYTHON_USEDEP}]
>=dev-python/jinja-2.3[${PYTHON_USEDEP}]
>=dev-python/pygments-2.0.1-r1[${PYTHON_USEDEP}]
>=dev-python/six-1.4[${PYTHON_USEDEP}]
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
=dev-python/alabaster-0.7*[${PYTHON_USEDEP}]
- =dev-python/sphinx_rtd_theme-0.1*[${PYTHON_USEDEP}]
>=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
latex? (
dev-texlive/texlive-latexextra
app-text/dvipng
)"
DEPEND="${DEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy) )"
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )"
+PDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
S="${WORKDIR}/${MY_P}"