summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-03 18:20:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-03 18:45:59 +0100
commit2cd75b5f120be4157309239ec3255da6df4e3239 (patch)
tree440db0c9e84d0d15eb69d2a8615495318bf5fb01 /dev-python/sphinx
parentapp-admin/sudo: ppc64 stable wrt bug #707574 (diff)
downloadgentoo-2cd75b5f120be4157309239ec3255da6df4e3239.tar.gz
gentoo-2cd75b5f120be4157309239ec3255da6df4e3239.tar.bz2
gentoo-2cd75b5f120be4157309239ec3255da6df4e3239.zip
dev-python/sphinx: Use typed-ast on py<3.8
dev-python/typed-ast is necessary for better typing support in py<3.8. This also fixes (hopefully last) test failures. Closes: https://bugs.gentoo.org/703140 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/sphinx-2.4.3-r1.ebuild (renamed from dev-python/sphinx/sphinx-2.4.3.ebuild)6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/sphinx/sphinx-2.4.3.ebuild b/dev-python/sphinx/sphinx-2.4.3-r1.ebuild
index 46f34931a946..8063e7053184 100644
--- a/dev-python/sphinx/sphinx-2.4.3.ebuild
+++ b/dev-python/sphinx/sphinx-2.4.3-r1.ebuild
@@ -37,6 +37,9 @@ RDEPEND="
dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typed-ast[${PYTHON_USEDEP}]
+ ' python3_{6,7})
latex? (
dev-texlive/texlive-latexextra
dev-texlive/texlive-luatex
@@ -64,7 +67,8 @@ python_prepare_all() {
rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
sed -i -e 's:test_latex_images:_&:' tests/test_build_latex.py || die
- # fail under pypy3
+ # fail under pypy3 (some because of missing typed-ast)
+ # revisit when pypy3 becomes pypy3.8
sed -i -e '/def test_partialfunction/i\
@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
-e '/def test_autodoc_typed_instance_variables/i\