summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:02:43 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:03:03 -0400
commit70300828c45a6688fee7e8661a8c32ddfc0446e8 (patch)
tree4b3216351bca2369abd2ed682c4a2ff9ab6db78b /dev-python/sphinx
parentdev-python/sphinxcontrib-qthelp: new package (diff)
downloadgentoo-70300828c45a6688fee7e8661a8c32ddfc0446e8.tar.gz
gentoo-70300828c45a6688fee7e8661a8c32ddfc0446e8.tar.bz2
gentoo-70300828c45a6688fee7e8661a8c32ddfc0446e8.zip
dev-python/sphinx: bump to 2.0.0
I removed the "net" USE flag because it does nothing else than adding dependencies that aren't referenced anywhere in the code. Moreover, the release that introduced it, 1.5.1, wasn't accompanied by a justification for its addition. I think that it was added for what is now "sphinxcontrib-websupport". If that's the case, then this doesn't belong here. Closes: https://bugs.gentoo.org/662322 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/Manifest1
-rw-r--r--dev-python/sphinx/sphinx-2.0.0.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index 1aded9f30831..8acce3aeae62 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -1,3 +1,4 @@
DIST Sphinx-1.2.2.tar.gz 3143671 BLAKE2B a21b2a060363ac86832a6a28a623ed410ff0bb39ca3c9c58618ade88f4305996e54c559bb588c518597e31a73fc16e0c37fc57950eb077179f03715dfee72729 SHA512 44073c215f9d0e7f6c7bc91cb85b0508a96e5cfff5f940fef86e2fc6f11281d03b54e87e51e5a99a23e96b470a93f3af86a6a3ab7c317c747406c55b4c37791c
DIST Sphinx-1.2.3.tar.gz 3200548 BLAKE2B 42033c59e6e38247af12c78cb4f69c73b1dfa883aa8a9e6c180bb74de666b45faef24a55c0bfd3aa1f22bf3e632e0e95016eb1bea54e8b5ebc7df78756763b5c SHA512 00346516e826a65145a3a7fd25ef7cee569ae7fdcc0c1bec3a7301fc08d5d8730d02eee792c3efedfcac17e712ea7e2ad70ea1fcdedc11720ad54f6bcb51ad05
DIST Sphinx-1.7.5.tar.gz 4726802 BLAKE2B 8d828dcae1f3ebb813c5f2de8c096a3fac4ab88b424955c27592349c544b775a21703c904a54efa7f86e1967198f4950804904a82a7142a3499f33c5343506e3 SHA512 db2a8df2cdb2ed78ce2341175575c2b04a149451b2bc8a4f74ddc73e308a19d505874fdbae4e370ce48a9b1cdb4de47cdab489bc57c1b378e857d5b8d04a07b8
+DIST Sphinx-2.0.0.tar.gz 6011308 BLAKE2B 72ec668522b803c07a76be086a27d2f8fb844558fc3d3a9fbaa7a191e570c23e3baa951873f68d3b54c48d8cfa770f8fd1549b718a7e760b7691bb686fe9e83d SHA512 283e18514262366e0aebc23f1e48ce7fa3591e48572525c832f96ec4f943463e19904c67ab06a4b3244119750c63dc496d4a4142e1e4a55e0b4ebdc748cf6aa6
diff --git a/dev-python/sphinx/sphinx-2.0.0.ebuild b/dev-python/sphinx/sphinx-2.0.0.ebuild
new file mode 100644
index 000000000000..779ccc6065cf
--- /dev/null
+++ b/dev-python/sphinx/sphinx-2.0.0.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="http://www.sphinx-doc.org/"
+SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc latex test"
+
+# Tests automagically use latex, bug 667414
+#REQUIRED_USE="test? ( latex )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/imagesize[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ latex? (
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/imagemagick-tools[jpeg,png,svg]
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+
+S="${WORKDIR}/${P^}"
+
+python_prepare_all() {
+ # remove tests that fail due to network-sandbox
+ rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
+ sed -i -e 's:test_latex_images:_&:' tests/test_build_latex.py || die
+ sed -i -e 's:test_latex_doc:_&:' tests/test_build_latex.py || die
+
+ # requires specific locales
+ sed -i -e 's:test_babel_with_language_:_&:' tests/test_build_latex.py || die
+ sed -i -e 's:test_polyglossia_with_language_:_&:' tests/test_build_latex.py || die
+
+ # fail for unknown reasons. TODO: find out why
+ sed -i -e 's:test_build_latex_doc:_&:' tests/test_build_latex.py || die
+ rm tests/test_ext_imgconverter.py || die "Failed to remove broken test"
+
+ # fails when additional sphinx themes are installed
+ sed -i -e 's:test_theme_api:_&:' tests/test_theming.py || die
+
+ # fail under pypy3
+ sed -i -e 's:test_partialmethod:_&:' tests/test_autodoc.py || die
+ sed -i -e 's:test_partialfunction:_&:' tests/test_autodoc.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # Generate the grammar. It will be caught by install somehow.
+ # Note that the tests usually do it for us. However, I don't want
+ # to trust USE=test really running all the tests, especially
+ # with FEATURES=test-fail-continue.
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
+ popd >/dev/null || die
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
+ local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}