summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-08-17 13:08:06 +0100
committerMarek Szuba <marecki@gentoo.org>2021-08-17 13:10:01 +0100
commit11fd7c235b72d6414a0e8af8a0096da2827f045e (patch)
tree45d84563d036ee23a62715ac477f220b9caf8754 /dev-python/sphinx_ansible_theme
parentdev-python/ansible-pygments: initial import (diff)
downloadgentoo-11fd7c235b72d6414a0e8af8a0096da2827f045e.tar.gz
gentoo-11fd7c235b72d6414a0e8af8a0096da2827f045e.tar.bz2
gentoo-11fd7c235b72d6414a0e8af8a0096da2827f045e.zip
dev-python/sphinx_ansible_theme: add 0.8.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_ansible_theme')
-rw-r--r--dev-python/sphinx_ansible_theme/Manifest1
-rw-r--r--dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sphinx_ansible_theme/Manifest b/dev-python/sphinx_ansible_theme/Manifest
index 698bdacea9b1..76c732aa3ccd 100644
--- a/dev-python/sphinx_ansible_theme/Manifest
+++ b/dev-python/sphinx_ansible_theme/Manifest
@@ -1,2 +1,3 @@
+DIST sphinx-ansible-theme-0.8.0.tar.gz 34401 BLAKE2B 493663331e593da8d56683991762452419fd5fdb48e2c59ee3a38b6242216bccf56e047e59294ae73cccfb48a66606e55fac6c9a19d91e6ea778920f9919dbd1 SHA512 399af992428dd3212681efa66036af9ae7dbd9a9dd507452686cc76aa3e365aabee0ba7b599fbbed85f1f252075d5158ade9a816a9aad17b4e5ed696be1c962e
DIST sphinx_ansible_theme-0.6.0.tar.gz 37606 BLAKE2B 3b27d15133e167602ce9515fb630ed9ecb0b0d346450417900e616476fa80aa216c033741121f82289d9e5bf977e01395663e5f61c4682576e8b773c17af2723 SHA512 d134a9e6eab0cab8e60c251a69e7b3dfa2864e5e19d65ce2e8b565a601e4b5255536f6b69ac17952ebd14929471a487200fc97c9c5e1f3f8232daf8e4ed63cef
DIST sphinx_ansible_theme-0.7.0.tar.gz 34120 BLAKE2B ce116d0392fd5feaf389bfc3c1934aa72eef4fe55d8307df0035e6d73824e2ebe0da48175a29703c5643c297ce5628f680089624046f10612ca6995a3f2b46b5 SHA512 4cb395eb02c5ea1bfb743af9fb71732b65d155d87064128b134b0561c6eaaa3239ad65be12cd90d704b7f80c32f97c544493f67027ccd03865dfa4a3c88e816e
diff --git a/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild
new file mode 100644
index 000000000000..d8c99b40ceb9
--- /dev/null
+++ b/dev-python/sphinx_ansible_theme/sphinx_ansible_theme-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PN="${PN//_/-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A reusable Ansible Sphinx theme"
+HOMEPAGE="https://github.com/ansible-community/sphinx_ansible_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ doc? ( dev-python/ansible-pygments[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs 'dev-python/sphinx-notfound-page'
+
+S="${WORKDIR}"/${MY_P}