summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 10:27:19 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 11:00:39 +0100
commit87e68abb659edb38c1502fa4236bf4b00ec03e13 (patch)
tree489539d46192420838bd1f7880fdf27647d6466f /dev-python/sphinx_rtd_theme
parentdev-python/readthedocs-sphinx-ext: Bump to 2.1.2 (diff)
downloadgentoo-87e68abb659edb38c1502fa4236bf4b00ec03e13.tar.gz
gentoo-87e68abb659edb38c1502fa4236bf4b00ec03e13.tar.bz2
gentoo-87e68abb659edb38c1502fa4236bf4b00ec03e13.zip
dev-python/sphinx_rtd_theme: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_rtd_theme')
-rw-r--r--dev-python/sphinx_rtd_theme/Manifest1
-rw-r--r--dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinx_rtd_theme/Manifest b/dev-python/sphinx_rtd_theme/Manifest
index c4bbe38c730a..a93f1092c5f9 100644
--- a/dev-python/sphinx_rtd_theme/Manifest
+++ b/dev-python/sphinx_rtd_theme/Manifest
@@ -1,2 +1,3 @@
DIST sphinx_rtd_theme-0.2.4.tar.gz 1392456 BLAKE2B daf2365d74823465a73ea37352f0a8e85f196ac9c89006e79610a2981b1a266e523865c3b6f7866fa9e77a856c5a6fe001a2eb114dcb252920b19231eade9709 SHA512 865b09febc1c289d47a8be3f3d7caa9d2a4715b350e2e2d058855831321a6f870e8339b2ef22eafc2b9fe72ad48f96b8d2fda4bc032c5f8dcdf23f314869cfbb
DIST sphinx_rtd_theme-0.4.3.tar.gz 5391190 BLAKE2B 6e08e079378c023f160fc3b858544bec6a295b256564d91c49b9ed8b5d2ee87bb2f21a30239f99fd2463840d194fde820c84ccd8e0b908f96fb7e5ca0fd9e6da SHA512 44b9309ddd041181542747c70b6e180c07aaf8cd7ee9e4c7eb9e3948685b8bd578e815c022bd991cc7f4bc7d02bb3c7a6d213e5d0c2e8214aa85d50b73e53853
+DIST sphinx_rtd_theme-0.5.1.tar.gz 2774928 BLAKE2B 1ff9c2e1b7ef7740de4969b6b4862d9ac499d515163a32ca2b5438c84910d610c80f5e8c3d03e3016ffa8c58003abecb67bd036ded065dfb65318e2f1d7e69d9 SHA512 20a04408fdf3f5698fecb2a0a430eba6f484770c8e01026c0d444d25ffcbd798edb82aa4b489df10b63d9fcc5eac204e9e3ccdaaf7eac7eb0baee2a5d7960c30
diff --git a/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild
new file mode 100644
index 000000000000..5f74a92cb962
--- /dev/null
+++ b/dev-python/sphinx_rtd_theme/sphinx_rtd_theme-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ReadTheDocs.org theme for Sphinx"
+HOMEPAGE="https://github.com/readthedocs/sphinx_rtd_theme"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE=""
+
+PDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/readthedocs-sphinx-ext[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # CI=1 disables rebuilding webpack that requires npm use
+ # yes, that surely makes sense
+ export CI=1
+}