summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-30 22:22:06 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:03:01 -0400
commitb70dfde12820939f3b42d1f16fefb6481c890ff2 (patch)
tree1505fd9c9f46970079b4a069a149b8d8bb7d7e63 /dev-python/sphinxcontrib-applehelp
parentdev-python/sphinxcontrib-htmlhelp: new package (diff)
downloadgentoo-b70dfde12820939f3b42d1f16fefb6481c890ff2.tar.gz
gentoo-b70dfde12820939f3b42d1f16fefb6481c890ff2.tar.bz2
gentoo-b70dfde12820939f3b42d1f16fefb6481c890ff2.zip
dev-python/sphinxcontrib-applehelp: new package
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp')
-rw-r--r--dev-python/sphinxcontrib-applehelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-applehelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/Manifest b/dev-python/sphinxcontrib-applehelp/Manifest
new file mode 100644
index 000000000000..6fe197d3360d
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-applehelp-1.0.1.tar.gz 22086 BLAKE2B 6e10329a1712cfcb1f29a3b4c23be5169507398a43f800623f2b24fd350f7e2ad16a887e87a3b68253dc348337342d3d4397d3a9d81a460c389a77ed4bdc973f SHA512 a6500bc2899f25c0b04c8649e86a6f688823e573a3f58f2b786117768e8b415acffbe79b99cff8aeb6ae3c74dd244254de120b82b7432cf61c5fabdd38f21603
diff --git a/dev-python/sphinxcontrib-applehelp/metadata.xml b/dev-python/sphinxcontrib-applehelp/metadata.xml
new file mode 100644
index 000000000000..5f2f3cd24f8e
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-applehelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild
new file mode 100644
index 000000000000..3cb06e3f8cc2
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}