summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-17 14:37:10 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-17 14:41:11 +0100
commit1fc9d2b69c7d60198c40cc868dfbe05e33dcfb28 (patch)
tree8b47c893aed41c823f9f374816ebfa91aab3745b /dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
parentmedia-video/vlc: Move dev-libs/libgpg-error under USE=gcrypt (diff)
downloadgentoo-1fc9d2b69c7d60198c40cc868dfbe05e33dcfb28.tar.gz
gentoo-1fc9d2b69c7d60198c40cc868dfbe05e33dcfb28.tar.bz2
gentoo-1fc9d2b69c7d60198c40cc868dfbe05e33dcfb28.zip
dev-python/sphinxcontrib-asyncio: Fix namespace cleanup
Closes: https://bugs.gentoo.org/625872
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
new file mode 100644
index 000000000000..ef4858611d7d
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="sphinx extension to support coroutines in markup"
+HOMEPAGE="https://github.com/aio-libs/sphinxcontrib-asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install() {
+ rm "${BUILD_DIR}"/lib/sphinxcontrib/__init__.py || die
+ distutils-r1_python_install --skip-build
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+ # clean up pth files bug #623852
+ find "${ED}" -name '*.pth' -delete || die
+}