summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-05 20:19:38 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-05 20:22:48 +0200
commitbc6456535a6fd42b98ee698e1b671a43a8b132b1 (patch)
tree943aeddb17f43aebdc34b30213c6c173992726af /dev-python/sphinxcontrib-blockdiag
parentdev-python/sphinxcontrib-asyncio: Bump to 0.3.0 (diff)
downloadgentoo-bc6456535a6fd42b98ee698e1b671a43a8b132b1.tar.gz
gentoo-bc6456535a6fd42b98ee698e1b671a43a8b132b1.tar.bz2
gentoo-bc6456535a6fd42b98ee698e1b671a43a8b132b1.zip
dev-python/sphinxcontrib-blockdiag: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-blockdiag')
-rw-r--r--dev-python/sphinxcontrib-blockdiag/Manifest1
-rw-r--r--dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-blockdiag/Manifest b/dev-python/sphinxcontrib-blockdiag/Manifest
index 020f13fd66c7..b7cfbc88d8e3 100644
--- a/dev-python/sphinxcontrib-blockdiag/Manifest
+++ b/dev-python/sphinxcontrib-blockdiag/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-blockdiag-2.0.0.gh.tar.gz 11903 BLAKE2B 9301fe05ff936836e8e648a507b7e2e5fd8cada58252fd46b274a4bb3e6b51b00b7696ceee712d12bd590c40c5ae1235e0b532ef55ffc2e78b2986cdae64a0f2 SHA512 305ad9b27bbb44480c69139cc0ae9cd8e47c6ad95da5b14a964c703a17e62ab9b342ff567e8312e403549a794f6381fe4c4d444ccb7a8e41410d1a3754ffb3f1
+DIST sphinxcontrib-blockdiag-3.0.0.gh.tar.gz 12300 BLAKE2B 4bb6e83625095aab209b3f8eff3f96dd0c0ff37c542bedd03d7b56be282bdb6929bba7ef9cbbc458492b17bfbcf80d705cb17b3f194213c1416bf1ab090fcc6a SHA512 1d03296007b0b6455fa25b1c0d3f09fb76dfaeba43ac7155033ec6fda0aaae40b757f6b77b63725489f2360eb5a80ce8e9e55eb6460b73c3b3bca363afe8aeac
diff --git a/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild
new file mode 100644
index 000000000000..63bb84ea4cc5
--- /dev/null
+++ b/dev-python/sphinxcontrib-blockdiag/sphinxcontrib-blockdiag-3.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A sphinx extension for embedding block diagrams using blockdiag"
+HOMEPAGE="
+ https://github.com/blockdiag/sphinxcontrib-blockdiag/
+ https://pypi.org/project/sphinxcontrib-blockdiag/
+"
+SRC_URI="
+ https://github.com/blockdiag/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/blockdiag-1.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/build-base/d" setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ rm -rf sphinxcontrib || die
+ distutils_write_namespace sphinxcontrib
+ eunittest
+}