summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-09-09 15:17:44 +0200
committerTiziano Müller <dev-zero@gentoo.org>2016-09-09 15:17:44 +0200
commita19bf525e663cf816483cab0643652d221b8db24 (patch)
treeedf93bf4f07ce500e13f6e7373dfee5ebe9e04ea /dev-python/sphinxcontrib-cheeseshop
parentdev-python/pyhamcrest: version bump (including EAPI 6 bump and py-3.5 support) (diff)
downloadgentoo-a19bf525e663cf816483cab0643652d221b8db24.tar.gz
gentoo-a19bf525e663cf816483cab0643652d221b8db24.tar.bz2
gentoo-a19bf525e663cf816483cab0643652d221b8db24.zip
dev-python/sphinxcontrib-cheeseshop: rev-bump for EAPI 6 bump and py-3.5 support
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/sphinxcontrib-cheeseshop')
-rw-r--r--dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r1.ebuild b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r1.ebuild
new file mode 100644
index 000000000000..3bf8d14389ee
--- /dev/null
+++ b/dev-python/sphinxcontrib-cheeseshop/sphinxcontrib-cheeseshop-0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension cheeseshop"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed \
+ -e '5s/file/open/' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}