summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 14:31:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:58:33 +0200
commit8ef007a989620687fcf98c68e326992ea3656f6e (patch)
tree578cc516560d2793f4222d1e78fc4ba4f35440f8 /dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.6.1.ebuild
parentnet-analyzer/barnyard: Old (diff)
downloadgentoo-8ef007a989620687fcf98c68e326992ea3656f6e.tar.gz
gentoo-8ef007a989620687fcf98c68e326992ea3656f6e.tar.bz2
gentoo-8ef007a989620687fcf98c68e326992ea3656f6e.zip
dev-python/sphinxcontrib-doxylink: bump to 1.6.1
add py37/38 Closes: https://bugs.gentoo.org/719566 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.6.1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.6.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.6.1.ebuild b/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.6.1.ebuild
new file mode 100644
index 000000000000..014c821b458f
--- /dev/null
+++ b/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to link to external Doxygen API documentation"
+HOMEPAGE="https://pypi.org/project/sphinxcontrib-doxylink/ https://pythonhosted.org/sphinxcontrib-doxylink/ https://github.com/sphinx-contrib/doxylink"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}