summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sphinxcontrib-googleanalytics
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sphinxcontrib-googleanalytics')
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/Manifest1
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch16
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/metadata.xml9
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild22
4 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-googleanalytics/Manifest b/dev-python/sphinxcontrib-googleanalytics/Manifest
new file mode 100644
index 000000000000..f338270f7eab
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-googleanalytics-0.1.tar.gz 2892 SHA256 92b7d74a45defb01e7d29e86fd8206eba42c896b2272cbd1b4b4f6a7d178d5a8 SHA512 fdec9108f9c1d86c6c59cd2bcfa55d82cd5cd48aca5b7aecec7734f3cd29b0f6c080aad7b7009148e3d95b7cf80af38ffb6ba230879495f3c1488ddb661fbf48 WHIRLPOOL 32115511eb21cdb7a202b9b63a4568f31f64a9d98d4dfd25cd6d15628cbd7873d8666f9969d25a3db569f25389d43028214d7d805ec07961c9d96f9991f9c10f
diff --git a/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch b/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
new file mode 100644
index 000000000000..b3b9f58d1b2d
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/files/setup.py.utf-8.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/show_bug.cgi?id=429914
+--- setup.py
++++ setup.py
+@@ -1,10 +1,11 @@
+ # -*- coding: utf-8 -*-
+
++import codecs
+ import os
+ from setuptools import setup, find_packages
+
+ HERE = os.path.dirname(os.path.abspath(__file__))
+-long_desc = open(os.path.join(HERE, 'README')).read()
++long_desc = codecs.open(os.path.join(HERE, 'README'), encoding='utf-8').read()
+
+ requires = ['Sphinx>=0.6']
+
diff --git a/dev-python/sphinxcontrib-googleanalytics/metadata.xml b/dev-python/sphinxcontrib-googleanalytics/metadata.xml
new file mode 100644
index 000000000000..f312ebabd5e6
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-googleanalytics</remote-id>
+ <remote-id type="bitbucket">birkenfeld/sphinx-contrib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild
new file mode 100644
index 000000000000..e289002df141
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension googleanalytics"
+HOMEPAGE="http://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/sphinx-0.6[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/setup.py.utf-8.patch" )