summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:41:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:53:07 +0200
commit16c4711fa0f19194aee4dae39774ea11a3f607fc (patch)
tree1d3a684d0d7eb185fc880f6119e0d02339b59769 /dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.3.ebuild
parentdev-python/sphinxcontrib-devhelp: Bump to 1.0.4 (diff)
downloadgentoo-16c4711fa0f19194aee4dae39774ea11a3f607fc.tar.gz
gentoo-16c4711fa0f19194aee4dae39774ea11a3f607fc.tar.bz2
gentoo-16c4711fa0f19194aee4dae39774ea11a3f607fc.zip
dev-python/sphinxcontrib-htmlhelp: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.3.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.3.ebuild
new file mode 100644
index 000000000000..1bc7cc2853dc
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-2.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp/
+ https://pypi.org/project/sphinxcontrib-htmlhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest