summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-02 15:51:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-02 16:16:36 +0100
commit12e588002560b28453d9f977b7fb92279cde67c0 (patch)
treec05511f4b0fb756187e3f9f49e219eb085f7821c /dev-python/sphinxcontrib-htmlhelp
parentdev-python/sphinxcontrib-jsmath: Add missing ns dep & tests (diff)
downloadgentoo-12e588002560b28453d9f977b7fb92279cde67c0.tar.gz
gentoo-12e588002560b28453d9f977b7fb92279cde67c0.tar.bz2
gentoo-12e588002560b28453d9f977b7fb92279cde67c0.zip
dev-python/sphinxcontrib-htmlhelp: Bump to 1.0.3, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-htmlhelp')
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-htmlhelp/Manifest b/dev-python/sphinxcontrib-htmlhelp/Manifest
index 50cc0c693bd9..ba60a608ac66 100644
--- a/dev-python/sphinxcontrib-htmlhelp/Manifest
+++ b/dev-python/sphinxcontrib-htmlhelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-htmlhelp-1.0.2.tar.gz 25417 BLAKE2B f5f13cebf0bdeb8065fa37b12d90dcb4cf4775377b2290517105bfdcfcd7a168d10b0c84a90cdcbefa95f0d40b6bb644532e75b5616562cc37c04e103ee7bc4b SHA512 2ee6c8a91095d8f87208ea509153edc5495b9ef78231add39880e133413b1fa95e152264e5c9dfe6afc89afcb107acacc241754e7b5d86137bb5c64a851702de
+DIST sphinxcontrib-htmlhelp-1.0.3.tar.gz 24248 BLAKE2B eeb7edd0bce99621ce6fa3a2bb9ba90a619af18403c8b4b0148a7d20fd3847f418f35bb1bb413531c0799b5b98be7b45aca51aa5c8120d9c997abb86ab0b0f01 SHA512 f37542c5789340bb26c41b84512e08998e4ef45ff2eb0fdb0e10f585cff27a145d5821b8eb3766d009e2b5a38c3d7efb127ab898982e1b6fd1d4ff7e26907db4
diff --git a/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.3.ebuild b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.3.ebuild
new file mode 100644
index 000000000000..60095391e984
--- /dev/null
+++ b/dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs HTML help book"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-htmlhelp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}