summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-02 12:58:27 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-02 12:58:27 +0100
commit852d34597b73d70381cb2c0cf099350fee36561c (patch)
tree08ad641c933f727dec76472e9069b08e9209ac96 /dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
parentdev-python/genty: Bump (diff)
downloadgentoo-852d34597b73d70381cb2c0cf099350fee36561c.tar.gz
gentoo-852d34597b73d70381cb2c0cf099350fee36561c.tar.bz2
gentoo-852d34597b73d70381cb2c0cf099350fee36561c.zip
dev-python/sphinxcontrib-httpdomain: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
new file mode 100644
index 000000000000..9b26fffb3fea
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpdomain/sphinxcontrib-httpdomain-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension providing a Sphinx domain for describing RESTful HTTP APIs"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib/ \
+ http://packages.python.org/sphinxcontrib-httpdomain/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"